Since RVM works its magic by manipulating your shell's environment, Textmate can't know what version of ruby you've activated using RVM. This is a headache for developers. Fortunately there's a quick fix in new versions of RVM.

For info on how to fix your textmate have a read here